eduroam/flake.nix

31 lines
1.0 KiB
Nix

{
description = "Description for the project";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
};
outputs = inputs@{ flake-parts, ... }:
flake-parts.lib.mkFlake { inherit inputs; } {
systems = [ "x86_64-linux" "aarch64-linux" "aarch64-darwin" "x86_64-darwin" ];
perSystem = { config, self', inputs', pkgs, system, ... }: {
packages = rec {
python = pkgs.python3.withPackages (ps: with ps; [ distro dbus-python ]);
default = pkgs.writeScriptBin "default"
''
${pkgs.lib.getExe python} ${./src/eduroam-linux-UL.py}
'';
intern = pkgs.writeScriptBin "intern" ''
${pkgs.lib.getExe python} ${./src/eduroam-linux-UL_fip.py}
'';
extern = pkgs.writeScriptBin "extern" ''
${pkgs.lib.getExe python} ${./src/eduroam-linux-UL_UB.py}
'';
medizin = pkgs.writeScriptBin "medizin" ''
${pkgs.lib.getExe python} ${./src/eduroam-linux-UL_MED.py}
'';
};
};
};
}